You are here

Alfresco Content Services upgrade paths

When you upgrade Alfresco Content Services, it is recommended that you follow a structured upgrade path between versions.

The following diagram shows the upgrade paths for major versions:

The upgrade path recommendations are:
  • Direct upgrades to Alfresco Content Services 6.0 are supported from only 5.0.x and later, with the latest Service Pack applied.
  • Alfresco Content Services 6.0 is a major version change, which introduces some changes that require new releases of all modules. To upgrade to 6.0, you also need to update any of the module artifacts to which you are entitled. See Supported Platforms for more details on the associated versions.
  • You must upgrade to Alfresco Search Services 1.2 before upgrading the repository to 6.0. See Upgrading Search Services for more information.
  • Upgrades from Alfresco 5.0 or 5.1 need to first stop at 5.2 to upgrade search to Search Services, and then upgrade to 6.0.
  • Upgrades from Alfresco 5.2 must first upgrade to Search Services from Solr 4, and then upgrade to 6.0.
  • See Upgrading from Alfresco Community Edition for guidance on upgrades from Alfresco Community Edition.
Note: If you are upgrading from an earlier release that is not shown on this diagram, contact Alfresco Support for assistance.

Sending feedback to the Alfresco documentation team

You don't appear to have JavaScript enabled in your browser. With JavaScript enabled, you can provide feedback to us using our simple form. Here are some instructions on how to enable JavaScript in your web browser.