You are here

Prerequisites for using Media Management

There are a number of software requirements for using Media Management.

You require one of each of the following components:

Software requirements

  • FFmpeg 2.5.4 from the command line for video transformations. See FFmpeg for information on how to download and use FFmpeg. Make sure that your FFmpeg installation has support for H.264 and AAC codecs. If FFmpeg is not available locally, Media Management functionality is reduced.
  • ExifTool 9.76 from the command line for full IPTC metadata extraction. See ExifTool for information about how to download and use ExifTool.
  • Apache ActiveMQ 5.15 or later. See Configuring ActiveMQ for more information about installing ActiveMQ.
  • ImageMagick 6.8.6-6 for image manipulation. See Installing ImageMagick for more information about installing ImageMagick.
    Note: If you are using RAW image formats, you must install an ImageMagick delegate, for example, UFRaw, to manipulate the images. See UFRaw for more information.

    To preview RAW image formats, you need to set additional configuration properties. See step 8 of Installing Media Management.

Note: FFmpeg and ExifTool are required to view media in Share. See step 8 of Installing Media Management for information on how to set these in the alfresco-global.properties file.

Alfresco requirements

Alfresco Content Services 6.1 or later.

Java requirements

OpenJDK 11 or later.

Remote transformation services (optional)

Sending feedback to the Alfresco documentation team

You don't appear to have JavaScript enabled in your browser. With JavaScript enabled, you can provide feedback to us using our simple form. Here are some instructions on how to enable JavaScript in your web browser.