You are here

Prerequisites for using Alfresco Outlook Integration

There are a number of software requirements for installing Alfresco Outlook Integration.

You need one of each of the following components:

Operating system requirements

You can use one of the following operating systems:

  • Microsoft Windows 10 with latest updates (only in combination with Outlook 2016)
  • Microsoft Windows 8.1 with latest updates
  • Microsoft Windows 7 with latest updates

Software requirements

You can use one of the following Outlook releases:

  • Microsoft Outlook 2016 (x86/x64)
  • Microsoft Office 2013 (x86/x64)
  • Microsoft Office 2010 (x86/x64)
  • Visual Studio Tools for Office 4.0 Runtime
  • Microsoft .NET Framework 4.5 or above (only in combination with Windows 7)

Alfresco requirements

  • Alfresco One 5.0.4 or later, Alfresco One 5.1.3 or later, and Alfresco Content Services 5.2.x. See Alfresco Supported Platforms for more information.

If you plan to use SAML Single Sign-On (SSO) for Alfresco Content Services authentication, check the requirements in Prerequisites for using SAML SSO with Alfresco.

Sending feedback to the Alfresco documentation team

You don't appear to have JavaScript enabled in your browser. With JavaScript enabled, you can provide feedback to us using our simple form. Here are some instructions on how to enable JavaScript in your web browser.