You are here

Requirements

There are certain requirements that need to be available before the Maven Alfresco SDK can be used.

Requirements for using the Maven Alfresco SDK 1.1.0 are:

  • Maven version 3.0.3+.
    Attention: It is strongly recommended that you use the official binary distributions of Apache Maven, downloaded from the official mirrors, and avoid OS-specific distributions as much as possible. If you have a pre-installed copy of Maven you should check it is a suitable version using the command mvn --version.
  • Java 1.7 if you want to run Alfresco Community 4.2.b and above, or Alfresco Enterprise 4.2.0 and above.

The Maven Alfresco SDK can be used in conjunction with popular IDEs such as Eclipse and IntelliJ IDEA. If using Eclipse ensure the latest version of the m2e add-on is installed.